logo
Welcome to our new AbleCommerce forums. As a guest, you may view the information here. To post to this forum, you must have a registered account with us, either as a new user evaluating AbleCommerce or an existing user of the application. For all questions related to the older version of Gold and earlier, please go to forums.ablecommerce.com. Please use your AbleCommerce username and password to Login. Forums Registration.

Notification

Icon
Error

Options
Go to last post Go to first unread
Joe Payne @ AbleMods LLC  
#1 Posted : Thursday, April 29, 2021 1:22:19 PM(UTC)
Joe Payne @ AbleMods LLC

Rank: Advanced Member

Groups: HelpDesk
Joined: 11/9/2018(UTC)
Posts: 172

Thanks: 49 times
Was thanked: 9 time(s) in 8 post(s)
Edit a volume discount
Change the User Groups from All Groups to Selected Groups
Click on the Groups selector box

The UI is listing every group names multiple times

And the _default group is not listed

Capture2.JPG (28kb) downloaded 0 time(s).

Wanna join the discussion?! Login to your AbleCommerce Forums forum account. Forums Registration.

shaharyartiwana25816656  
#2 Posted : Saturday, May 1, 2021 7:45:27 AM(UTC)
shaharyar

Rank: Advanced Member

Groups: Admin, Developers, Registered, HelpDesk, Authorized User
Joined: 10/5/2018(UTC)
Posts: 460

Thanks: 1 times
Was thanked: 46 time(s) in 46 post(s)
For me, this is not happening on a 9.0.4 install. Can you confirm that there are no duplicate entries in your database?

Or are there any specific steps that I can follow to reproduce this on my end? Thanks!
Joe Payne @ AbleMods LLC  
#3 Posted : Monday, May 3, 2021 5:16:26 AM(UTC)
Joe Payne @ AbleMods LLC

Rank: Advanced Member

Groups: HelpDesk
Joined: 11/9/2018(UTC)
Posts: 172

Thanks: 49 times
Was thanked: 9 time(s) in 8 post(s)
I see the problem. Somehow all of the primary security groups have been duplicated multiple times in ac_Groups, each one with a different StoreId. Now it makes sense why Admin->Admin Groups only shows one of each group. The grid results are correctly filtered for the current StoreId.

But that group selector on Volume Discounts must not be filtering by StoreId which is why the duplicates are rendering. I think that's the real bug in this case.

This was an AC7 site upgraded to Able v903. Then a week ago we updated to v904. We kept the old ac7 database, so I checked there. The groups are duplicated in AC7 too. No idea how that could have happened, but this site has been around for a long time.

I'll do some checking to see if anything else has something with StoreId > 1.

A question: If a license key works for multiple domain names, would that create multiple StoreId values in the data? In 13 years of working on Able, I've never seen this specific issue before.

Capture3.JPG (90kb) downloaded 2 time(s).
shaharyartiwana25816656  
#4 Posted : Monday, May 3, 2021 6:03:34 AM(UTC)
shaharyar

Rank: Advanced Member

Groups: Admin, Developers, Registered, HelpDesk, Authorized User
Joined: 10/5/2018(UTC)
Posts: 460

Thanks: 1 times
Was thanked: 46 time(s) in 46 post(s)
Quote:
A question: If a license key works for multiple domain names, would that create multiple StoreId values in the data? In 13 years of working on Able, I've never seen this specific issue before



A license for multiple domains does not create multiple StoreId values in the data
thanks 1 user thanked shaharyar for this useful post.
Joe Payne @ AbleMods LLC on 5/3/2021(UTC)
judy at Web2Market  
#5 Posted : Tuesday, May 4, 2021 6:10:33 AM(UTC)
judy at Web2Market

Rank: Advanced Member

Groups: Developers
Joined: 11/7/2018(UTC)
Posts: 135

Thanks: 7 times
Was thanked: 2 time(s) in 2 post(s)
I don't remember for AC7, but for AC5, you could have multiple stores in the same database. So maybe that site started out as an AC5 site.
Joe Payne @ AbleMods LLC  
#6 Posted : Friday, May 7, 2021 1:34:00 PM(UTC)
Joe Payne @ AbleMods LLC

Rank: Advanced Member

Groups: HelpDesk
Joined: 11/9/2018(UTC)
Posts: 172

Thanks: 49 times
Was thanked: 9 time(s) in 8 post(s)
Followup:

The client had 5 additional store instances in ac_Stores. They have no idea how that happened. To clean it up, I did a delete in ac_Stores on StoreId > 1. Initially this kept throwing foreign key constraint violations. But that tells you the table where you've got to clean up separately. So just clean those up with the same StoreId > 1 delete command eventually you'll get where ac_Stores will clean up as well.

So far no issues noted.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.