logo
Welcome to our new AbleCommerce forums. As a guest, you may view the information here. To post to this forum, you must have a registered account with us, either as a new user evaluating AbleCommerce or an existing user of the application. For all questions related to the older version of Gold and earlier, please go to forums.ablecommerce.com. Please use your AbleCommerce username and password to Login. Forums Registration.

Notification

Icon
Error

Options
Go to last post Go to first unread
judy at Web2Market  
#1 Posted : Wednesday, July 28, 2021 9:49:50 AM(UTC)
judy at Web2Market

Rank: Advanced Member

Groups: Developers
Joined: 11/7/2018(UTC)
Posts: 155

Thanks: 14 times
Was thanked: 2 time(s) in 2 post(s)
Original post was https://www.ablecommerce...forums/posts/t720-ShopBy and AC provided a patch there so that clicking on a shopby option filtered the products on the category page.
I've run across two bugs:
If the merchant field name has an apostrophe in it, it throws the error that it can't find the named parameter storeId when it is clicked on.
Shouldn't the shop by selection display in the left nav be filtered based on the products in the category being viewed? As it is, they show all the time, but if you are in a category where none of the products use the shop by and you click on one of the selections, you get a display that no products match your search criteria.

Edited by user Wednesday, July 28, 2021 9:51:31 AM(UTC)  | Reason: Not specified

Wanna join the discussion?! Login to your AbleCommerce Forums forum account. Forums Registration.

judy at Web2Market  
#2 Posted : Wednesday, July 28, 2021 9:59:31 AM(UTC)
judy at Web2Market

Rank: Advanced Member

Groups: Developers
Joined: 11/7/2018(UTC)
Posts: 155

Thanks: 14 times
Was thanked: 2 time(s) in 2 post(s)
One more note- I just set this up and tested on a Gold R12 site and it didn't show the shop by unless you were in a category where products used it.
shaharyar  
#3 Posted : Wednesday, July 28, 2021 10:28:26 AM(UTC)
shaharyar

Rank: Advanced Member

Groups: Admin, Developers, Registered, HelpDesk, Authorized User
Joined: 10/5/2018(UTC)
Posts: 530

Thanks: 2 times
Was thanked: 76 time(s) in 75 post(s)
Quote:
If the merchant field name has an apostrophe in it, it throws the error that it can't find the named parameter storeId when it is clicked on.


I am able to reproduce the issue. I am registering.

Quote:
Shouldn't the shop by selection display in the left nav be filtered based on the products in the category being viewed? As it is, they show all the time, but if you are in a category where none of the products use the shop by and you click on one of the selections, you get a display that no products match your search criteria.


UPDATED:

I am able to verify the claim. In Gold, it is working as you are pointing out. I will log this issue as well.

Thanks for pointing this out!

Edited by user Wednesday, July 28, 2021 10:36:54 AM(UTC)  | Reason: Not specified

Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.