logo
Welcome to our new AbleCommerce forums. As a guest, you may view the information here. To post to this forum, you must have a registered account with us, either as a new user evaluating AbleCommerce or an existing user of the application. For all questions related to the older version of Gold and earlier, please go to forums.ablecommerce.com. Please use your AbleCommerce username and password to Login. Forums Registration.

Notification

Icon
Error

Options
Go to last post Go to first unread
speedythinker1832579  
#1 Posted : Saturday, July 25, 2020 6:57:01 PM(UTC)
speedythinker1832579

Rank: Advanced Member

Groups: Authorized User, Developers
Joined: 5/20/2019(UTC)
Posts: 48

Thanks: 1 times
For some reason, we received a lot of declined payment from Authorize.net. The issue was AVS (billing address matched) but I checked that and found that most billing address that customer provided were matched. Plus, it happened to a lot of return customers who made purchased products from us with the same card and address! Moreover, I even lowered AVS security level from Authorize.net trying to get the issue fixed but it is still happening.

BTW, I'm still receiving 100s error message from the V9 after the upgrade. I also reported another issue about not being able to receive from a "Contact us" form. I paid my hosting company to fix a bunch of coding issues. Now they were tired to do it for me not willing to do it. If things didn't get solved soon, I may be thinking to switch over to Shopify or other e-commerce platforms.

The Gold V7 was much less trouble than the V9


Marco


Wanna join the discussion?! Login to your AbleCommerce Forums forum account. Forums Registration.

ray22901031  
#2 Posted : Sunday, July 26, 2020 9:11:46 PM(UTC)
ray22901031

Rank: Advanced Member

Groups: Authorized User, Developers
Joined: 2/17/2019(UTC)
Posts: 112

Thanks: 2 times
Was thanked: 2 time(s) in 2 post(s)
Hi Marco,

In regards to the AVS issue, the only thing Ablecommerce has to do is pass the billing information to the gateway. That billing information includes the first numerical part of the billing address and the billing ZIP Code. That's the only two pieces of information the gateway uses to check AVS.

What AVS responses are you getting from authorize.net?

B, E, R, G, U, S, N, A, Z,W, or Y ???

I believe these are the only responses issued by authorize.net. Ablecommerce does not participate in the decision to deny a credit card payment once the information has been sent to your gateway,you better check with authorize.net to see what security settings you have in place. Also look at the AVS response and make a determination from there.

Even return customers can use different billing addresses and different credit cards. The only restriction we have on our end is deny the purchase if the security code is incorrect, again setting at the gateway level, not the shopping cart.

I'm sorry to hear about the other issues that you're having, I have found that if you properly document and Ablecommerce can verify the issue, they will even give you code fixes before the next release. At least that has been my experience working with them for a short time.

I am pretty sure you are aware that if you move to Shopify, once you have 800k in sales, you're going to be locked into the $2,000 plus shopping cart fee? - You are aware of this, correct?

Best of luck in fixing your issue,
-Ray

Edited by user Monday, July 27, 2020 7:13:55 AM(UTC)  | Reason: Not specified

Naveed Ashraf  
#3 Posted : Monday, July 27, 2020 11:52:36 PM(UTC)
Naveed Ashraf

Rank: Advanced Member

Groups: Admin, Administrators, Developers, Registered, HelpDesk, Authorized User
Joined: 7/31/2019(UTC)
Posts: 55

Was thanked: 3 time(s) in 3 post(s)
Hi Marco,

I'm sorry to hear about the issues you are having. I have provided code updates related to your Contact Us issue. It seems more of an issue with your SMTP server then the Contact Us form, still its easy to be updated and workaround. Please check the respective thread.


Regarding your Authorize.Net issue, Ray seems right. It may be some issue with your Authorize.net security configurations as no such issue is reported.

To investigate this issue , we need some more details:

1. What AVS responses are you getting from authorize.net?
2. Please enable the debug mode for Authorize.net gateway (if not already enabled) and provide SEND and RECEIVE log for some failing transactions.

You can locate the log data under ~/App_Data/Logs/Authorize.NET CIM.Log file.

Thanks.
Thanks for your support!
Naveed Ashraf
Ablecommerce.com
Developer Assistance Available
speedythinker1832579  
#4 Posted : Wednesday, July 29, 2020 4:45:37 PM(UTC)
speedythinker1832579

Rank: Advanced Member

Groups: Authorized User, Developers
Joined: 5/20/2019(UTC)
Posts: 48

Thanks: 1 times
B(decline) E(decline) R(Allow & Report) G(Authroize & Hold) U(Authorize & Hold) S(Allow & Report)

N(decline) A(Allow & report) Z(Allow & Report) W(Allow & Report) Y(Allow)


Made changed today
N(decline) A(Allow & report) Z(Authroize & Hold) W(Authroize & Hold) Y(Allow)



All these settings are considered very loose on the security checks. The problem was that a lot of customers used the same card and the same billing address got declined because of AVS mismatched. How could it be? We double-checked it all info matched.
speedythinker1832579  
#5 Posted : Wednesday, July 29, 2020 4:49:08 PM(UTC)
speedythinker1832579

Rank: Advanced Member

Groups: Authorized User, Developers
Joined: 5/20/2019(UTC)
Posts: 48

Thanks: 1 times
For the Contact Form, my hosting company edited the code and worked before seeing a reply here.
But there was a minor issue: can't just click reply because the "Sener" is addressed to ourselves. So, we have to copy the actual sender email address and pasted it to "To:"
This is a common issue for the SMTP mail server and I think you guys need to address it. It is a very common practice to use SMTP service to relate emails.

Thx
ray22901031  
#6 Posted : Wednesday, July 29, 2020 6:30:25 PM(UTC)
ray22901031

Rank: Advanced Member

Groups: Authorized User, Developers
Joined: 2/17/2019(UTC)
Posts: 112

Thanks: 2 times
Was thanked: 2 time(s) in 2 post(s)
I really suggest that you follow Naveed advice and send him what he is requesting, the Authorize.NET CIM.Log file.

If Ablecommerce is properly passing the information to your gateway, you have a gateway problem.

-Ray
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.