logo
Welcome to our new AbleCommerce forums. As a guest, you may view the information here. To post to this forum, you must have a registered account with us, either as a new user evaluating AbleCommerce or an existing user of the application. For all questions related to the older version of Gold and earlier, please go to forums.ablecommerce.com. Please use your AbleCommerce username and password to Login. Forums Registration.

Notification

Icon
Error

Options
Go to last post Go to first unread
gdavis26370087  
#1 Posted : Friday, January 22, 2021 3:45:36 PM(UTC)
gdavis26370087

Rank: Newbie

Groups: Registered, Developers
Joined: 1/22/2021(UTC)
Posts: 0

I've tried all the settings I can think of and I just can't get this thing to email through office 365. I've tried port 587, 465 and 25, all to no avail.

I've opened up the firewall to allow all outbound traffic and it still doesn't send. Am I missing something or does this not support the required authentication mechanisms?

Wanna join the discussion?! Login to your AbleCommerce Forums forum account. Forums Registration.

gdavis26370087  
#2 Posted : Friday, January 22, 2021 4:38:11 PM(UTC)
gdavis26370087

Rank: Newbie

Groups: Registered, Developers
Joined: 1/22/2021(UTC)
Posts: 0

Here is the official error in the logs. Notice it's trying to do a SendAs. Where do I change that?

Error sending email with subject 'dev.callifd.com: SMTP Settings Updated'. View less
Exception: Transaction failed. The server response was: 5.2.0 STOREDRV.Submission.Exception:SendAsDeniedException.MapiExceptionSendAsDenied; Failed to process message due to a permanent exception with message Cannot submit message. 0.35250:31170000, 1.36674:0A000000, 1.61250:00000000, 1.45378:02000000, 1.44866:2C1F0000, 1.36674:0E000000, 1.61250:00000000, 1.45378:311F0000, 1.44866:E0010000, 16.55847:570F0000, 17.43559:0000000024020000000000000000000000000000, 20.52176:140FC88E0F00103100000000, 20.50032:140FC88E7F17000000000000, 0.35180:140FC88E, 255.23226:57180000, 255.27962:0A000000, 255.27962:0E000000, 255.31418:88180000, 0.35250:02013781, 1.36674:0A000000, 1.61250:00000000, 1.45378:02000000, 1.44866:5C000000, 1.36674:32000000, 1.61250:00000000, 1.45378:61000000, 1.44866:01000000, 16.55847:C8000000, 17.43559:0000000098030000000000000000000000000000, 20.52176:140FC88E0F00101053000000, 20.50032:140FC88E7F1700001E000000, 0.35180:58000000, 255.23226:4800D13D, 255.27962:0A000000, 255.27962:32000000, 255.17082:DC040000, 0.27745:28000000, 4.21921:DC040000, 255.27962...Stack Trace: at System.Net.Mail.DataStopCommand.CheckResponse(SmtpStatusCode statusCode, String serverResponse) at System.Net.Mail.DataStopCommand.Send(SmtpConnection conn) at System.Net.ClosableStream.Close() at System.Net.Mail.SmtpClient.Send(MailMessage message) at CommerceBuilder.Messaging.EmailClient.Send(MailMessage mailMessage, SmtpSettings smtpSettings, Boolean throwOnError)
shaharyartiwana25816656  
#3 Posted : Sunday, January 24, 2021 11:21:09 PM(UTC)
shaharyartiwana25816656

Rank: Advanced Member

Groups: Admin, Developers, Registered, HelpDesk, Authorized User
Joined: 10/5/2018(UTC)
Posts: 215

Thanks: 1 times
Was thanked: 33 time(s) in 33 post(s)
Hi,

https://www.ablecommerce...e-through-email#post1594

Please go through this post and a solution is also shared. May be this is related to your problem.

Also, there are details in the following post as well.
https://stackoverflow.co...drv-submission-exception
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.