logo
Welcome to our new AbleCommerce forums. As a guest, you may view the information here. To post to this forum, you must have a registered account with us, either as a new user evaluating AbleCommerce or an existing user of the application. For all questions related to the older version of Gold and earlier, please go to forums.ablecommerce.com. Please use your AbleCommerce username and password to Login. Forums Registration.

Notification

Icon
Error

Options
Go to last post Go to first unread
Joe Payne @ AbleMods LLC  
#1 Posted : Friday, April 23, 2021 10:35:18 AM(UTC)
Joe Payne @ AbleMods LLC

Rank: Advanced Member

Groups: HelpDesk
Joined: 11/9/2018(UTC)
Posts: 172

Thanks: 49 times
Was thanked: 9 time(s) in 8 post(s)
Both 9.0.3 installs I have upgraded to 9.0.4 this week did not execute the SQL schema changes. I had to open the SQL script from the upgrade folder and execute it manually in both cases.

We really need some sort of upgrade UI when an upgrade is executing. As it is now, there is zero feedback that an upgrade was even attempted, or failed or not found etc.

Wanna join the discussion?! Login to your AbleCommerce Forums forum account. Forums Registration.

shaharyartiwana25816656  
#2 Posted : Monday, May 3, 2021 3:15:40 AM(UTC)
shaharyar

Rank: Advanced Member

Groups: Admin, Developers, Registered, HelpDesk, Authorized User
Joined: 10/5/2018(UTC)
Posts: 460

Thanks: 1 times
Was thanked: 46 time(s) in 46 post(s)
Our initial released zip file was missing the upgrade folder that was added later on. Perhaps this had happened because of the missing folder.

We have now tried this many times and found this to be working as expected.
I would like to request if you can try once more and confirm that this issue still persists.

Thanks
Joe Payne @ AbleMods LLC  
#3 Posted : Monday, May 3, 2021 5:28:40 AM(UTC)
Joe Payne @ AbleMods LLC

Rank: Advanced Member

Groups: HelpDesk
Joined: 11/9/2018(UTC)
Posts: 172

Thanks: 49 times
Was thanked: 9 time(s) in 8 post(s)
Ok, so I probably have the old/bad download. Is there a specific folder that was missing that I can look for?

I should just go the admin Upgrades->Past Upgrades and download the 9.0.4 again to get the working 9.0.4 upgrade right?

shaharyartiwana25816656  
#4 Posted : Monday, May 3, 2021 5:51:31 AM(UTC)
shaharyar

Rank: Advanced Member

Groups: Admin, Developers, Registered, HelpDesk, Authorized User
Joined: 10/5/2018(UTC)
Posts: 460

Thanks: 1 times
Was thanked: 46 time(s) in 46 post(s)
Quote:
Ok, so I probably have the old/bad download. Is there a specific folder that was missing that I can look for?


Only, the Upgrades folder under App_Data folder was missing. YOu will get the folder with a fresh download from the same link.

Joe Payne @ AbleMods LLC  
#5 Posted : Monday, May 3, 2021 12:22:40 PM(UTC)
Joe Payne @ AbleMods LLC

Rank: Advanced Member

Groups: HelpDesk
Joined: 11/9/2018(UTC)
Posts: 172

Thanks: 49 times
Was thanked: 9 time(s) in 8 post(s)
In an existing live 9.0.4 install, there is only one entry under Past Upgrades. There is no download link or button. And the Instructions button links to an invalid url that throws a 404 http://help.ablecommerce.com/upgrade/9.0.4.6750/

Technically shouldn't ALL past upgrades be shown in that list? Otherwise, what's the point of the Past Upgrades feature?
Joe Payne @ AbleMods LLC  
#6 Posted : Monday, May 3, 2021 12:29:32 PM(UTC)
Joe Payne @ AbleMods LLC

Rank: Advanced Member

Groups: HelpDesk
Joined: 11/9/2018(UTC)
Posts: 172

Thanks: 49 times
Was thanked: 9 time(s) in 8 post(s)
So then based on what you've said...

We can't use a fresh-install version of 9.0.4 to upgrade an existing Able v9 site since it does not include the /App_Data/Upgrade/ folder. We must use the specific upgrade downloads to perform any upgrade to an existing Able v9 install. However you can use a fresh install of v9 to upgrade Able v7 or Able Gold because that upgrade happens via the install process.

Is my understanding correct?
shaharyartiwana25816656  
#7 Posted : Tuesday, May 4, 2021 12:32:36 AM(UTC)
shaharyar

Rank: Advanced Member

Groups: Admin, Developers, Registered, HelpDesk, Authorized User
Joined: 10/5/2018(UTC)
Posts: 460

Thanks: 1 times
Was thanked: 46 time(s) in 46 post(s)
Yes, this is correct!



In an existing 9.0.3 install, you can download the latest upgrade zip (9.0.3 to 9.0.4) from the available upgrades list. This will contain the Upgrade Folder under App_Data.


Quote:
I had to open the SQL script from the upgrade folder and execute it manually in both cases


Also, I just noticed that in your first comment you mentioned that you have found the Upgrade folder and executed the scripts manually.


Quote:
Technically shouldn't ALL past upgrades be shown in that list? Otherwise, what's the point of the Past Upgrades feature?


Surely the upgrades section needs some improvements and we had opened a discussion for improvements.

Thanks

Edited by user Tuesday, May 4, 2021 12:47:23 AM(UTC)  | Reason: Not specified

Joe Payne @ AbleMods LLC  
#8 Posted : Tuesday, May 4, 2021 7:30:30 AM(UTC)
Joe Payne @ AbleMods LLC

Rank: Advanced Member

Groups: HelpDesk
Joined: 11/9/2018(UTC)
Posts: 172

Thanks: 49 times
Was thanked: 9 time(s) in 8 post(s)
Ok thanks for the clarification.

In one hand, I like having the SQL scripts available to run manually for a couple of reasons. 1) I can see what's been changed in case it impacts a customization, and 2) I can run it manually if necessary.

However with that said, this upgrade process is guaranteed to grow more challenging going forward. Client's don't upgrade every release. In a few years, we're going to see 903 installs that need to upgrade to 908. based on how the upgrade system is designed now, those upgrades are going to be a serious pain to perform.

We should be making upgrades easier, not harder, to do.
ray22901031  
#9 Posted : Tuesday, May 4, 2021 12:08:19 PM(UTC)
ray22901031

Rank: Advanced Member

Groups: Authorized User, Developers
Joined: 2/17/2019(UTC)
Posts: 348

Thanks: 2 times
Was thanked: 5 time(s) in 5 post(s)
If I can interject something here based on my post with the language strings. I was not aware that there was a cvs file under the area\install\content directory for this.

If I can suggest the following, having a text file with the manual scripts necessary to upgrade the schema in the database. It can be one text file that gets updated per version. Using Joe's example of going from 9.0.3 to 9.0.8, the text file would have an entry to upgrade the schema to 9.0.4 and if there was a schema change in 9.0.5, that information would also be listed there with the proper sql statement to run.

I do not believe that this would be a major burden on AbleCommerce, but can definitely save a lot of developers plenty of time. Maybe a directory under area\install called schema.

Just an idea,
-Ray
judy at Web2Market  
#10 Posted : Wednesday, May 5, 2021 6:05:22 AM(UTC)
judy at Web2Market

Rank: Advanced Member

Groups: Developers
Joined: 11/7/2018(UTC)
Posts: 135

Thanks: 7 times
Was thanked: 2 time(s) in 2 post(s)
I would also suggest having the readme for the upgrade available after the upgrade. Since the upgrade disappears in the admin after it is done, the instructions disappear also so you can't go back and make sure you've done everything correctly if there is an issue.
shaharyar  
#11 Posted : Thursday, May 6, 2021 1:44:07 AM(UTC)
shaharyar

Rank: Advanced Member

Groups: Admin, Developers, Registered, HelpDesk, Authorized User
Joined: 10/5/2018(UTC)
Posts: 460

Thanks: 1 times
Was thanked: 46 time(s) in 46 post(s)
Thank you all for your suggestions. We have a report opened for upgrade process improvements.

Quote:
I would also suggest having the readme for the upgrade available after the upgrade. Since the upgrade disappears in the admin after it is done, the instructions disappear also so you can't go back and make sure you've done everything correctly if there is an issue.


After an upgrade, you will see an entry on the past upgrades page with an instruction page link.

Thanks
ray22901031  
#12 Posted : Thursday, May 6, 2021 9:31:28 AM(UTC)
ray22901031

Rank: Advanced Member

Groups: Authorized User, Developers
Joined: 2/17/2019(UTC)
Posts: 348

Thanks: 2 times
Was thanked: 5 time(s) in 5 post(s)
>>> After an upgrade, you will see an entry on the past upgrades page with an instruction page link. <<<

Where is this past upgrade page located?

Thanks
shaharyar  
#13 Posted : Friday, May 7, 2021 1:00:36 AM(UTC)
shaharyar

Rank: Advanced Member

Groups: Admin, Developers, Registered, HelpDesk, Authorized User
Joined: 10/5/2018(UTC)
Posts: 460

Thanks: 1 times
Was thanked: 46 time(s) in 46 post(s)
menu.png (16kb) downloaded 0 time(s).
ray22901031  
#14 Posted : Friday, May 7, 2021 1:08:45 AM(UTC)
ray22901031

Rank: Advanced Member

Groups: Authorized User, Developers
Joined: 2/17/2019(UTC)
Posts: 348

Thanks: 2 times
Was thanked: 5 time(s) in 5 post(s)
This is what you get!

404 - File or directory not found.
The resource you are looking for might have been removed, had its name changed, or is temporarily unavailable.
ray22901031  
#15 Posted : Friday, May 7, 2021 1:09:52 AM(UTC)
ray22901031

Rank: Advanced Member

Groups: Authorized User, Developers
Joined: 2/17/2019(UTC)
Posts: 348

Thanks: 2 times
Was thanked: 5 time(s) in 5 post(s)
Also, no info on version 9.0.3
shaharyar  
#16 Posted : Friday, May 7, 2021 1:18:50 AM(UTC)
shaharyar

Rank: Advanced Member

Groups: Admin, Developers, Registered, HelpDesk, Authorized User
Joined: 10/5/2018(UTC)
Posts: 460

Thanks: 1 times
Was thanked: 46 time(s) in 46 post(s)
Sorry for the inconvinience. The URL added was invalid.

For now you can use the URL: http://help.ablecommerce...o_AbleCommerce_9.0.4.htm
ray22901031  
#17 Posted : Friday, May 7, 2021 1:25:15 AM(UTC)
ray22901031

Rank: Advanced Member

Groups: Authorized User, Developers
Joined: 2/17/2019(UTC)
Posts: 348

Thanks: 2 times
Was thanked: 5 time(s) in 5 post(s)
You are still missing information, if you read Judy's post she's making reference to the readme.txt file which is nowhere to be found after the upgrade.

What's so important about this file?

For me, you have information on language string settings that you do not provide online. If you could also provide this text file included in that upgrade, that would make a tremendous difference.

I hope this helps,
-Ray
shaharyar  
#18 Posted : Friday, May 7, 2021 1:54:51 AM(UTC)
shaharyar

Rank: Advanced Member

Groups: Admin, Developers, Registered, HelpDesk, Authorized User
Joined: 10/5/2018(UTC)
Posts: 460

Thanks: 1 times
Was thanked: 46 time(s) in 46 post(s)
Judy was suggesting to have a readme file to review if everything is done correctly.
So I just mentioned that you can review using the instructions link appearing in past upgrades.

If I am still not missing something!
ray22901031  
#19 Posted : Friday, May 7, 2021 2:04:02 AM(UTC)
ray22901031

Rank: Advanced Member

Groups: Authorized User, Developers
Joined: 2/17/2019(UTC)
Posts: 348

Thanks: 2 times
Was thanked: 5 time(s) in 5 post(s)
Let me be a little bit more specific, below this email message you will find the readme file for the upgrade for version 9.0.2. As you can see this file has quite a bit of information, but for me it has localization stings information.

Sometimes I'm so busy that I lose things, right now I'm missing the upgrade text file for 9.0.3, nowhere on your site can I find this file. In the future I'll be more careful, but right now I'm having some issues with the localization stings and would like to know what was added and at what version.

I hope this clarifies things - thanks


====================================
AbleCommerce version 9.0.2 - build 6218
Date of Release: March 24th, 2020.
----------------------------------------------------------\

Upgrade from AbleCommerce 9.0.1 (build 5867) to 9.0.2 (build 6218)

- Access to the server running AbleCommerce will be required.

- This release will upgrade AbleCommerce 9.0.1.5867 only.

- A valid subscription license is required; ends on or after 03/24/2020

----------------------------------------------------------\

### Installation Instructions ###

TO VERIFY THE DOWNLOAD:
**********************************************************\

1. Go to WinMD5.com or any other utility that can provide checksum validation.

2. Download the .zip file, and run the MD5 utility.

3. Select the downloaded for 'AbleCommerce Upgrade to 9.0.2'

4. In the field provided, copy the MD5 hash provided below, or displayed on the Upgrade page.

d78398f06328bca4fa407cde104aae48

5. Click Verify and confirm the number is a match.

6. If the validation fails, do NOT install the patch. Instead, open a support ticket at our website.

TO INSTALL THE UPGRADE:
**********************************************************\

7. Extract contents to a temporary location on the server.

\Lib\ --> files in this location are provided to developers; do not install these to the server.

\Website\ --> files and folders located here are installed to the website.

8. Backup the website and database to a separate location.

9. Stop the website using IIS.

10. Copy everything from \Website\ to the actual website root folder, matching folders and file locations.

11. Restart the website using IIS.

12. Login to the merchant admin so that any database changes will take effect.

----------------------------------------------------------\

### Post-Upgrade Instructions ###

A few localization strings will need to be updated manually.

1. After logging in to the admin, go to Configure > Store > Languages.
2. Click the 'Edit Resources' button to access the Resources page.
3. Use the Filter resource "Name" field to search/filter on each (total of 3) of the following:

retail.accountlogin.forgotpasswordusername_valid
Email address should be in the format of name@domain.tld.

retail.forgotpasswordpanel.if_the_email_address_entered_is_found_an_email_will_be_sent_containing_a_link_to_create_a_new_password
If the email address entered is found, an email will be sent containing a link to create a new password.

retail.mycredentials.username_regexvalidate
User name is not valid

4. For each search result, edit the resource. Change the translated string and save.

----------------------------------------------------------\



Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.