logo
Welcome to our new AbleCommerce forums. As a guest, you may view the information here. To post to this forum, you must have a registered account with us, either as a new user evaluating AbleCommerce or an existing user of the application. For all questions related to the older version of Gold and earlier, please go to forums.ablecommerce.com. Please use your AbleCommerce username and password to Login. Forums Registration.

Notification

Icon
Error

Options
Go to last post Go to first unread
Joe Payne @ AbleMods LLC  
#1 Posted : Friday, September 11, 2020 9:00:36 AM(UTC)
Joe Payne @ AbleMods LLC

Rank: Advanced Member

Groups: Developers
Joined: 11/9/2018(UTC)
Posts: 92

Thanks: 11 times
Was thanked: 5 time(s) in 5 post(s)
I see several issues with the view-order/Payments page

Steps to reproduce:

Set up AuthNet gateway using live creds. Set to test url, test mode. Yes, use live creds but leave it set to test mode. This guarantees every test is a failed payment.

Place an order and defer payment at end, or just pull up an existing order

Click to add a payment to the order

attempt to process a payment



The payment fails due to bad credentials because the AuthNet setup is configured with live creds, not test creds. So the failure is expected.

At the bottom you correctly see one transaction in the transaction history with a status of failed.

Under Payment Status on right you see one button 'Retry Authorization'.

Click the retry button. Add the CVV in the popup and submit.

Now we have several problems:

1. Transaction history for that payment still shows just one entry. It should be showing two transactions - one for the initial attempt and another for the retry.
2. I'm now seeing a 'Receive Payment' button which wasn't there before.
3. 'Retry Authorization' button is gone.
4. 'Authorize' button now visible but does nothing.

When a payment is successful, the UI is confusing:

1. Under the section 'Fraud Report:' there are two lines, AVS and CVV each with links. However no actual data is rendered here. These links just throw up a reference page of AVS and CVV code values. This isn't any sort 'fraud report'.

2. AVS reference page is badly outdated. The correct AVS response codes and their meanings can be found here https://support.authoriz...rvice-AVS-Response-Codes

Wanna join the discussion?! Login to your AbleCommerce Forums forum account. Forums Registration.

katie_able_support  
#2 Posted : Tuesday, September 15, 2020 4:00:59 PM(UTC)
katie_able_support

Rank: Advanced Member

Groups: Administrators, Developers, Registered, HelpDesk, System
Joined: 10/29/2018(UTC)
Posts: 94

Thanks: 2 times
Was thanked: 6 time(s) in 5 post(s)
Hi Joe,

I just saw your post now. I'm sorry that it wasn't recognized before today. Let me see if we can get it fixed for the upcoming release.

Thanks for providing such excellent details. I appreciate that.

Katie
Thanks for your support!
Katie
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.